カテゴリー別アーカイブ: ruby

ruby環境(v1.8.7)の構築

こんにちは★しょうたんは今日も元気です。
今回はなかなか素直に構築されてくれないruby環境のインストール作業内容を
エラー時の対処と併せて発表します(パチパチ←自分で拍手)
環境はCentOS release 5.8 (Final)での出来事ですw

rubyはバージョンによって仕様が違うので、rubyのバージョンによって
rubyのパッケージ管理であるgemもバージョンの制限がある事が注意点です。
因みに、今回はruby1.8.7なのでgemを別途パッケージからインストールしていますが、
ruby1.9.2以降ではgemのインストールの仕方が異なります。

■rubyとrdocのインストール

※既にruby環境がインストールされていた場合、ruby周りを一旦アンインストールします。
# yum remove ruby

# yum install ruby
# yum install rdoc

■gem1.3.7のインストール

# wget http://rubyforge.org/frs/download.php/70696/rubygems-1.3.7.tgz
# tar xvfz rubygems-1.3.7.tgz
# cd rubygems-1.3.7
# ruby setup.rb

gemのバージョンを確認する
# gem -v

■Ruby1.8.7をインストール

# wget ftp://ftp.ruby-lang.org/pub/ruby/1.8/ruby-1.8.7-p249.tar.bz2
# tar jvxf ruby-1.8.7-p249.tar.bz2
# cd ruby-1.8.7-p249
# ./configure
# make
# make install
# make clean

rubyのバージョンを確認する
# ruby -v

■railsのインストール

# gem install rails

※バージョン指定してインストールする場合
gem install rails –version 3.0
※完了までが長いので注意

※rdocがインストールされていない場合、railsインストール時以下のエラーが出る
ERROR: While executing gem … (Gem::DocumentError)
ERROR: RDoc documentation generator not installed: no such file to load — rdoc/rdoc

※例えばRuby1.8.7 以上入れる必要がある場合は以下のエラーが出る
このエラーはバージョン依存で最もでやすエラーなので、まずバージョンの確認から
ERROR: Error installing rails:
activesupport requires Ruby version >= 1.8.7

以上になります。
余談ですが例えばruby版のmakeのようなビルドツールであるrakeを使う場合も、railsとのバージョン制限がありますので注意です。
バージョン関連で制約だらけなのがruby環境ってことでOKでしょうか。
お疲れさまでした☆